Differences between revisions 16 and 17
Revision 16 as of 2016-10-27 10:07:12
Size: 1875
Editor: asbesto
Comment:
Revision 17 as of 2016-10-27 13:54:45
Size: 3408
Editor: asbesto
Comment:
Deletions are marked like this. Additions are marked like this.
Line 20: Line 20:
apt-get install joe mc git build-essential autoconf autopoint apt-get install joe mc git build-essential autoconf autopoint check
Line 37: Line 37:
./configure --prefix=/usr --disable-pulseaudio --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba --disable-systemd --enable-sdl --disable-avahi --disable-gstreamer1 ./configure --prefix=/usr --disable-pulseaudio --disable-avahi --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba --disable-systemd --enable-sdl --disable-avahi --disable-gstreamer1 --with-opengl=full
}}}

NOTE:
{{{

In case of error:

./configure: line 8396: syntax error near unexpected token `win32-dll'
./configure: line 8396: `LT_INIT(win32-dll disable-static pic-only)'

do

root@rover:/home/asbesto/Desktop/src/e/efl# aclocal
configure.ac:276: warning: macro 'AM_GNU_GETTEXT_VERSION' not found in library
configure.ac:285: warning: macro 'AM_GNU_GETTEXT' not found in library
configure.ac:374: warning: macro 'AM_PATH_LIBGCRYPT' not found in library

and

root@rover:/home/asbesto/Desktop/src/e/efl# autoreconf -i
configure.ac:285: warning: The 'AM_PROG_MKDIR_P' macro is deprecated, and its use is discouraged.
configure.ac:285: You should use the Autoconf-provided 'AC_PROG_MKDIR_P' macro instead,
configure.ac:285: and use '$(MKDIR_P)' instead of '$(mkdir_p)'in your Makefile.am files.

and try again. IT DOESNT WORK. FUCK THAT SHIT

edita configure alla riga 8396 e leva la merda di riga, che non c'entra un cazzo, rilancia configure and you see that works.


Those are unnecessary, graphic acceleration will be use automagically if available.

  --enable-fb enable raw Framebuffer access. [default=disabled]
  --enable-eglfs enable hardware accelerated framebuffer access.
                          [default=disabled]
  --enable-drm enable drm engine. [default=disabled]
  --enable-gl-drm enable gl drm engine. [default=disabled]

  --enable-egl enable EGL rendering. [default=disabled]

Enlightenment

light.gif

This wiki page is just a scratchpad for now. It may become a sort of howto, who knows?!? ;)

Install from sources

Git repo:

BASE install without hardware accelerations and amusements

On your system, if you're trying the damnation of their git repos:

apt-get install joe mc git build-essential autoconf autopoint check 

efl

 git clone git://git.enlightenment.org/core/efl.git

Require:

apt-get install doxygen libssl-dev libjpeg-dev libsdl2-dev libluajit-5.1-dev libfribidi-dev libgif-dev libtiff-dev libmount-dev libblkid-dev libsndfile1-dev x11proto-print-dev libxp-dev libxtst-dev libbullet-dev 

Compile with:

./autogen.sh # only if configure is missing

./configure --prefix=/usr --disable-pulseaudio --disable-avahi --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba --disable-systemd --enable-sdl --disable-avahi --disable-gstreamer1 --with-opengl=full

NOTE:

In case of error:

./configure: line 8396: syntax error near unexpected token `win32-dll'
./configure: line 8396: `LT_INIT(win32-dll disable-static pic-only)'

do

root@rover:/home/asbesto/Desktop/src/e/efl# aclocal
configure.ac:276: warning: macro 'AM_GNU_GETTEXT_VERSION' not found in library
configure.ac:285: warning: macro 'AM_GNU_GETTEXT' not found in library
configure.ac:374: warning: macro 'AM_PATH_LIBGCRYPT' not found in library

and

root@rover:/home/asbesto/Desktop/src/e/efl# autoreconf -i
configure.ac:285: warning: The 'AM_PROG_MKDIR_P' macro is deprecated, and its use is discouraged.
configure.ac:285: You should use the Autoconf-provided 'AC_PROG_MKDIR_P' macro instead,
configure.ac:285: and use '$(MKDIR_P)' instead of '$(mkdir_p)'in your Makefile.am files.

and try again. IT DOESNT WORK. FUCK THAT SHIT

edita configure alla riga 8396 e leva la merda di riga, che non c'entra un cazzo, rilancia configure and you see that works. 


Those are unnecessary, graphic acceleration will be use automagically if available.

  --enable-fb             enable raw Framebuffer access. [default=disabled]
  --enable-eglfs          enable hardware accelerated framebuffer access.
                          [default=disabled]
  --enable-drm            enable drm engine. [default=disabled]
  --enable-gl-drm         enable gl drm engine. [default=disabled]

  --enable-egl            enable EGL rendering. [default=disabled]

elementary

 git clone git://git.enlightenment.org/core/elementary.git

enlightenment

 git clone git://git.enlightenment.org/enlightenment.git

connman / econnman

connman isn't an E package, so apt-get install connman ! :)

for econnman you need:

 git clone git://git.enlightenment.org/bindings/python/python-efl.git

and

 git clone git://git.enlightenment.org/apps/econnman.git

or use packages by Martinx - ジェームズ (Devuan community)

 ppa:martinx/enlightenment

Repositories for E18/E19 ?

 sudo add-apt-repository ppa:niko2040/e19
 sudo apt-get update
 sudo apt-get install enlightenment

Enlightenment (last edited 2020-03-06 15:26:21 by asbesto)