Differences between revisions 1 and 96 (spanning 95 versions)
Revision 1 as of 2009-08-06 16:05:05
Size: 1409
Editor: asbesto
Comment:
Revision 96 as of 2019-11-08 16:23:23
Size: 26973
Editor: asbesto
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
#acl FreaknetGroup:read,write,admin,delete,revert All:
Template di base per pagine freaknet, con acl settate in base a FreakNetGroup. -asb
As root:

1. apt-get install libpam-gnome-keyring


2. if you don't have it, create a file named

/etc/pam.d/common-pamkeyring

containing:

## page was renamed from UbuntuPurification
## page was renamed from UbuntuAvoidPasswords
#acl FreaknetGroup:read,write,admin,delete,revert All:read

= GNU/Linux PURIFICATION =
{{attachment:fuck2.jpg}}

'''Last update: Nov 3, 2019'''

<<TableOfContents(5)>>

Once upon a time, this was a page dedicated only to ubuntu distro; since many years I'm not using that shit anymore so this page evolved for general usage; the tricks described can be applied (with some minor tweaks) to almost any distro.

It's also my personal notepad for installing / dealing with my laptop, actually a Lenovo Thinkpad X220

I used Linux Mint for a lot of time, but they passed to the dark side ot that shitty cancer called systemd.

Now I'm using OUR distro, DEVUAN, a systemd-free old style full working GNU/Linux system! http://devuan.org :)

If you want to help developing this document, please write to asbesto (at) gmail {dot} com

Old version of this document is [[UbuntuPurificationOld]]

Check also:

 * [[Enlightenment]]
 * DebianSettings
 * ThinkpadFanControl

== Fresh devuan install: CLEANUP and SHIT ==

First we eradicate all the poettering bloatware shit, then we install what's needed in a serious UNIX system.

{{{

apt purge pulseaudio avahi-daemon avahi-autoipd

apt install joe mc openssh-server build-essential apt-file locate qasmixer aptitude bsdgames

updatedb
apt-file update

}}}

== THIS FUCKING TOUCHPAD ==

Once it was working. They broke it. Again.

Now, I have installed here xserver-xorg-input(libinput AND synaptics).

I don't touch anything than /etc/X11/xorg.conf, with this inside:

{{{

Section "Device"
  Identifier "Sucaminchia"
  Driver "intel"
EndSection

Section "dri"
  Mode 0666
EndSection

Section "InputClass"
    Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
            Option "TapButton1" "1"
            Option "TapButton2" "2"
            Option "TapButton3" "3"
        Option "VertEdgeScroll" "on"
        Option "HorizEdgeScroll" "on"
EndSection

}}}

On my thinkpad this is all I need. Touchpad is now working.


On the ASUS I have installed xinput (but I don't use it so I think isn't needed) and synclient.

Now, I can use synclient.

To enable tap to click: synclient TapButton1=1

Before, I had the edge scroll area TOO BIG, so to enlarge the touch pad area: synclient RightEdge=6100

There's NO FUCKING WAY to save those settings: everything in /usr/share/X11/xorg.conf.d/ is totally IGNORED.

So I tried .xsessionrc but it wasn't working either!!!

I had to create /usr/local/bin/synmerda:

{{{
#!/bin/bash
sleep 5
/usr/bin/synclient TapButton1=1
/usr/bin/synclient RightEdge=6100
touch /tmp/usrlocalbin-synmerda
}}}

the 5 sec delay is NECESSARY because if not, for some FUCKING REASON, synclient settings can't work! FUUUUUUCK

and this in .xsessionrc:

{{{
/usr/local/bin/synmerda &
touch /tmp/PUTTANAMADONNA-puntoxsessionrc
}}}


== About the poettering shit: avahi and pulseaudio removal ==

avahi and pulseaudio. Never saw such a pile of CRAP. let apt purge be, as shown before.

If you have some software that use pulseaudio crap and that you want to keep, use apt-mark. For example, I have this problem with pd-extended, so

{{{
apt-mark hold pd-extended # (because it depend on the pulseaudio-utils crap!!!)
}}}

So, to remove pulseaudio crap, use:

{{{
apt-get --ignore-hold purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio gstreamer1.0-pulseaudio pavucontrol
}}}

To install everything needed for ALSA sound:

{{{
apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0
}}}

=== Installing software that require that pulseaudio CRAP as dependency ===

Example: pd-extended is by default compiled / linked / whatever to the fucking pulseaudio CRAP. In my Linux Mint it depends on the package ''pulseaudio-utils''.

So, let's create a '''FAKE pulseaudio-utils package''', just to keep apt quiet about it.

Install the "equivs" package:

{{{
apt-get install equivs
}}}

and use it to create a fake pkg description:

{{{
equivs-control pulseaudio-utils
}}}

This will create a file named '''pulseaudio-utils''' in the local directory. Edit it to something like this: (you can just copy this stuff into it: it works! :) )

{{{
Section: misc
Priority: optional
Standards-Version: 3.9.2

Package: pulseaudio-utils
Version: 1:42
Maintainer: Fuck Pulseaudio <fuckpulseaudio@example.com>
Architecture: all
Description: Pulseaudio FUCK YOU!
}}}

Note the '''Version''': it prevent any overinstallation due to the very high value (42 ;) )

Now, create the fake package:

{{{
equivs-build ./pulseaudio-utils
}}}

And now, just install it:

{{{
dpkg -i ./pulseaudio-utils_42_all.deb
}}}

And so, now the dependency is satisfied and you have not to worry anymore! You can now install pd-extended and tweak his configuration to work with ALSA or JACK. ;)

* Very useful reference: http://shallowsky.com/blog/linux/install/blocking-deb-dependencies.html

=== mplayer and pulseaudio/alsa setup ===

You must configure the audio output in /etc/mplayer/mplayer.conf as follow:

{{{
# fuck pulse, use alsa, then SDL video
ao=alsa,sdl
}}}

=== updatedb, locate, mlocate ===

Here I just say 2 things:

 * DEBIAN SHIT!!!
 * INSTALL "mlocate", not "locate" !!!

=== audacious mp3 player ===

It must be configured (ctrl-p) as follow:

{{{
ALSA,
Sysdefault:card=mid hda intel mix default analog audio dev,
mixer hw:0 hda intel mid,
mixer element PCM.
}}}


=== ALSA and BLUETOOTH. FORGET IT! ===

'''EXPERIMENTAL: I FAILED. I can have a bt connection and direct aplay to use it, but there's no fucking way to switch from computer to bluetooth in any mixer I tried. So it's fucking useless apart from command line.'''


Scratchpad follow

 * https://github.com/Arkq/bluez-alsa

sbc is needed:

{{{
git clone git://git.kernel.org/pub/scm/bluetooth/sbc.git
cd sbc/
less INSTALL
./bootstrap-configure
./configure
make
sudo make install
}}}


{{{

root@rover:~# apt-get remove pulseaudio
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libpulsedsp libsbc1 libwebrtc-audio-processing1 pulseaudio-utils rtkit
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  pulseaudio pulseaudio-module-bluetooth
0 upgraded, 0 newly installed, 2 to remove and 1 not upgraded.
After this operation, 6,285 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 146018 files and directories currently installed.)
Removing pulseaudio-module-bluetooth (10.0-1+deb9u1) ...
Removing pulseaudio (10.0-1+deb9u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
root@rover:~#


asbesto@rover:~/Desktop/src$ git clone https://github.com/Arkq/bluez-alsa.git
Cloning into 'bluez-alsa'...
remote: Enumerating objects: 104, done.
remote: Counting objects: 100% (104/104), done.
remote: Compressing objects: 100% (75/75), done.
remote: Total 3213 (delta 49), reused 62 (delta 28), pack-reused 3109
Receiving objects: 100% (3213/3213), 1.24 MiB | 1.05 MiB/s, done.
Resolving deltas: 100% (2472/2472), done.

asbesto@rover:~/Desktop/src$ cd bluez-alsa/
}}}

REQUIREMENTS: sudo apt install libbluetooth-dev libfdk-aac-dev libfdk-aac1

{{{
asbesto@rover:~/Desktop/src/bluez-alsa$ autoreconf --install

(blah blah)

mkdir build && cd build
}}}

NOTE: NO /usr/local prefix here, I want config files in the right places.

{{{
../configure --enable-aac --enable-ofono --enable-debug

make

sudo make install
}}}

launch "bluealsa" from /etc/rc.local

{{{
 bluealsa -S &
}}}

{{{
cat > ~/.asoundrc

defaults.bluealsa.service "org.bluealsa"
defaults.bluealsa.device "55:0B:D4:79:E3:30"
defaults.bluealsa.profile "a2dp"
defaults.bluealsa.delay 10000

aplay -D bluealsa file.wav works!
}}}

No mixer can see / recognize the "bluealsa" device. FUCK THIS SHIT

AND:

''It is not possible to run more than one instance of the BlueALSA server per D-Bus interface. If one tries to run second instance, it will fail with the "Couldn't acquire D-Bus name: org.bluealsa" error message. This message might also appear when D-Bus policy does not allow acquiring "org.bluealsa" name for a particular user - by default only root is allowed to start BlueALSA server.''

what the actual FUCK


'''TO REVERT AND RE-INSTALL PULSESHIT'''

Uninstall bluez-alsa from the install directory (enter "build" dir and do make uninstall)

and


{{{

apt install pulseaudio pulseaudio-module-bluetooth

}}}

Sorry. If you want alsa instead of pulseshit, you can't use bluetooth.


NOTE:

I had chrome on external bt audio and telegram on pc auto. To set default output:

{{{
pactl set-default-sink 1
}}}

tnx to Nightolo! :)

{{{
asbesto@rover:~$ pactl list sinks > petazzo
asbesto@rover:~$ pactl list sources >> petazzo
asbesto@rover:~$ pacmd list sink-inputs > petazzo
asbesto@rover:~$ pactl set-default-sink 1
asbesto@rover:~$

}}}


=== Acrobat reader for linux ===

Get it from here: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/


{{{

dpkg --add-architecture i386
sudo apt-get update
dpkg -i Desktop/AdbeRdr9.5.5-1_i386linux_enu.deb

}}}

After that, fix the broken install shit and install the last requirement:

{{{

apt --fix-broken install
apt install libxml2:i386

}}}

That's it!


== Too many password asked. Why removing them? Is it safe? ==

Typical situation is: my laptop have only my personal account in it, and no other users. no open ports, no ssh server, no telnet, no shared folders, no samba, nothing.

I'm the only user of it.

{{{
So I log in (password),
and configure a printer (password),
I check network settings (password)
install packages (password),
remove a package (password again)
become su (password),
use sudo! (another password),
configure stuff in gnome (password again)
configure a new network connection (password again!!!)
quit the system (another password!!!)
}}}

''THIS - IS - FUCKING - STUPID''

This document contain useful hints to CLEAN UP THIS MESS, obtaining a nice working GNU/Linux system instead of the crap installed and configured by default.

== Automatic login without password ==

It's MY computer, in MY house, so why the FUCK i have to type my password to log in X-Windows?!?

{{{
System - Administration - Login and select the damn user
}}}

You can select this while installing Linux Mint.

== OLD: IDIOT keyring password ==

It will be asked again and again. Every time the same FUCKING password.
Just to open a thing that contain THE SAME PASSWORD ITSELF.
Delete the folder '''''$home/.gnome2/keyrings''''' which holds the keyring info. Once you do that it wont ask again.

On Mint 13 - Maya (mate edition), these files are at: '''$home/.config/mate/keyrings''' ''(Thanks to Derrik Arenal for the suggestion!)''

=== OLD: Disable the damn Gnome Keyring Manager Password ===

Where is it in Mint 17?

{{{
FUCK MINT 17 KEEPS ASKING PASSWORDS AND KEYRING FILE IS NO MORE IN THE PLACe
THIS IS AN EMERGENCY PLEASE HELP WHERE THE HELL IT IS NOW -jrml
}}}

=== Get rid of all those asked passwords ===

Create a file named '''/etc/pam.d/common-pamkeyring''' with this inside:

{{{
Line 17: Line 432:


3. edit /etc/pam.d/gdm adding this line at the bottom of the file:
}}}

Edit '''/etc/pam.d/mdm''' as follow: (was gdm but this is Mint! it can be lightdm - check it out)

add
{{{
Line 22: Line 439:

and please COMMENT OUT those lines:
}}}

at the bottom,
and please COMMENT OUT those lines:

{{{
Line 28: Line 446:


4.
Create, if doesn't exist, the "wheel" group, editing /etc/group, and add your user to it

5. add this in /etc/sudoers using "visudo":

yourusername ALL = NOPASSWD: ALL

6. add those things in
/etc/pam.d/sudo :
}}}

Create, if doesn't exist, the '''wheel''' group, editing '''/etc/group''', and add your user to it

{{{
vi /etc/group
}}}

Edit '''/etc/sudoers''', using '''visudo'''

{{{
visudo
}}}

adding:

{{{
%w
heel ALL=(ALL:NOPASSWD) ALL
yourusername ALL=(ALL) NOPASSWD: ALL
}}}

Edit '''
/etc/pam.d/sudo''' adding at bottom:

{{{
Line 43: Line 474:

7. enable this in your /etc/pam.d/su
}}}

Edit '''/etc/pam.d/su''' enabling this line (just uncomment it):

{{{
Line 49: Line 482:

8. edit /etc/PolicyKit/PolicyKit.conf as here:
}}}

== The Incredible Idiocy: PolicyKit ==

As I stated in ubuntuforums time ago:

''I'm used to work on MY computer, with MY login, and no other logins; it's in MY home, and it don't run away to search for malicious users. It's MY PC in MY HOUSE. For this I log in automagically with no password asking. I have automagic "su" and "sudo" without password (that is STUPID because I'm root on MY machine, and there are NO other users).

But now I have some very annoying issues about this damn thing called
"System Policy", for which I can't, just to say, do a shutdown of my machine under Gnome because "System policy prevents stopping the system when other users are logged". And this just because I have some root terminals left open.

This is very, very stupid.

And so on, this damn system policy crap keep asking me the same damn password for everything: wifi connections, login/ssh to other machines, mounting of devices, and so on.

Please, PLEASE. Does someone know HOW TO KILL this stupid thing? How to get rid of all those unuseful, boring, recursive and idiot password requests?

please somebody help me, I'm going nuts for this.''

I got an official warning and the thread was closed by administrator. The PolicyKit was a so stupid PIECE OF CRAP that now is no more used. But for the unfortunate users that have this stinking corpse running in the system, here's a solution.

Assuming you have sudo settings as above, do

{{{
usermod -aG sudo yourname
}}}

Replace "username" with your actual user name.
Now switch to root:

{{{
sudo -i
}}}

Create a new policy:

{{{
vi /var/lib/polkit-1/localauthority/50-local.d/fuck-passwords.pkla
}}}

Add this:

{{{
[Install package file]
Identity=unix-group:sudo
Action=*
ResultActive=yes
}}}

Save, exit, and reboot. No more Policy Kit password requests!

=== OLD POLKIT VERSION patch ===

As stated in the man page just edit '''/etc/PolicyKit/PolicyKit.conf''' as here:
Line 61: Line 546:

9. restart the whole X damn thing


AND LIVE IN HAPPINESS
and restart the whole X damn thing

'''NOW LIVE IN HAPPINESS'''

== Other stupid things ==

=== Debian Suggested and Recommended package automatic installation ===

Sometimes the default behaviour of Debian is to install unuseful CRAP as "recommended" and "suggested" packages. Here's how to avoid it:

{{{
vim /etc/apt/apt.conf.d/fucksuggested.conf
}}}

{{{
APT:Install-Recommends "0";
APT:Install-Suggests "0";
}}}

''(thanks to Franco Lanza for this hint! ;) )''

=== ls -la: BAD sorting order ===

The normal behaviour of '''ls -la''' command since beginning of UNIX is, and has to be:

{{{
-rw-r--r-- 1 sm01 sm01 0 May 3 18:32 .aaa
-rw-r--r-- 1 sm01 sm01 0 May 3 18:33 .fff
-rw-r--r-- 1 sm01 sm01 0 May 3 18:33 DDD
-rw-r--r-- 1 sm01 sm01 0 May 3 18:33 EEE
-rw-r--r-- 1 sm01 sm01 0 May 3 18:32 bbb
-rw-r--r-- 1 sm01 sm01 0 May 3 18:32 ccc
}}}

Now with all this LOCALE SHIT around, you can obtain this:

{{{
-rw-r--r-- 1 sm01 sm01 0 may 3 18:32 .aaa
-rw-r--r-- 1 sm01 sm01 0 may 3 18:32 bbb
-rw-r--r-- 1 sm01 sm01 0 may 3 18:32 ccc
-rw-r--r-- 1 sm01 sm01 0 may 3 18:33 DDD
-rw-r--r-- 1 sm01 sm01 0 may 3 18:33 EEE
-rw-r--r-- 1 sm01 sm01 0 may 3 18:33 .fff
}}}

If you want to avoid this fucking abomination, just add

{{{
export LC_COLLATE="C"
}}}
to your .bash_profile .zshrc or /etc/rc.local ;)

''(Thanks to Fabio "Elettrico" Moretti for this hint ;) )''


=== Pulseaudio CRAP ===

Pulseaudio is CRAP added for stupid reasons. A system without Pulseaudio is more responsive and everything work fine without this fucking daemon sucking about 13% of a Netbook CPU. So, get rid of it!

On my Linux Mint 15 Mate Edition, I just removed it:

{{{
apt-get purge pulseaudio
}}}

Nothing has changed on my system, and so I have 13% CPU free :) I can play everything as usual.

=== Command not found handler ===

I hate it. It slow the responsivness of my shell. so

{{{
apt-get remove command-not-found command-not-found-data
}}}

=== Close this terminal? ===

Are you kidding? YES, CLOSE THAT FUCKING TERMINAL, HOLY SHIT

Terminal asking "Close this terminal? There is still a process running in this terminal. Closing the terminal will kill it" is '''really, really stupid and BORING'''.

Install dconf-tools

{{{apt-get install dconf-tools}}}


Launch dconf-editor -> org -> mate -> terminal -> global -> untick confirm_window_close

=== Sticky Windows at edges ===

The most annoying thing in the entire world. The great stupid thing is that you have '''''compiz installed without the tool for configuring it!'''''

so, '''apt-get install compizconfig-settings-manager''' and check out the '''snapping windows''' option in the '''''window management''''' section of the compiz config editor, that is under '''''system - preferences''''' menu.

This setup can also be found into other parts of Desktop Manager configuration...

=== USEFUL programs that are not installed by default ===
 
 * traceroute - incredible. traceroute is not installed by default. O_O
 * compizconfig-settings-manager (compiz INSTALLED and NOT CONFIGURABLE? STUPID!)
 * openssh-server (this is SO FUGKING STUPID!)
 * mc
 * gimp
 * joe

=== SHIT to be removed ===

 * f-spot
 * totem (totally unuseful!)
 * conduit (Who give a FUCK to sync ?!?)

== About this document, his License/Terms of Use, etc. ==

'''
{{{
Copyright © 2000 Gabriele "asbesto" Zaverio <asbesto@gmail.com>
This work is free. You can redistribute it and/or modify it under the
terms of the Do What The Fuck You Want To Public License, Version 2,
as published by Sam Hocevar. See http://www.wtfpl.net/ for more details.
}}}
'''

=== WTFPL License ===

{{{

            DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
                    Version 2, December 2004

 Copyright (C) 2004 Sam Hocevar <sam@hocevar.net>

 Everyone is permitted to copy and distribute verbatim or modified
 copies of this license document, and changing it is allowed as long
 as the name is changed.

            DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
   TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

  0. You just DO WHAT THE FUCK YOU WANT TO.

}}}


=== Is this document offensive / inappropriate / not corporate compliant for you? ===

I want to cite the WTFPL about this:

'''Can’t you change the wording? It’s inappropriate / childish / not corporate-compliant.'''

''The WTFPL lets you relicense the work under any other license.''

'''But profanity is offensive!'''

''You know what? Fuck your stance on profanity. Fuck your priorities in life. The WTFPL is about fucking freedom and we mean it. Freedom means freedom to copy and modify and share works of art and science with the rest of mankind, but also freedom to be gay and marry and have crazy gay sex, freedom to have tattoos, freedom to say there is no God, freedom to take the pill, freedom to have an abortion. People die for being gay or atheists. Don’t tell me that there is something sacred enough that it must be protected from the mere existence of the word “fuck”. If the F in WTFPL offends you, then fuck you and your beliefs. Triple fuck you.''

== Old UBUNTU-related stuff ==

=== Threads about stupid things added in Ubuntu ===

 * http://ubuntuforums.org/showthread.php?p=9440671
 * http://ubuntuforums.org/showthread.php?t=1229939 60 seconds delay at shutdown request.
 * http://ubuntuforums.org/showthread.php?t=1232140 same as before
 * http://ubuntuforums.org/showthread.php?p=8954666 Log off password!!!
 * http://ubuntuforums.org/showthread.php?t=1233849 Too many passwords asked, a lot of stupid answers, and the thread CLOSED while discussing. O_o
 * http://ubuntuforums.org/showthread.php?t=1232131 The "System Policy" CRAP, another thread CLOSED by administrators! O_O


=== Totem ===

Totem is installed by default. But it's UNABLE to open ANYTHING. WHY?

NO CODECS INSTALLED!

O_O

=== Ubuntu 10.04 horrible windows layout ===

The default windows appearence in Ubuntu 10.04 is a SHAME. The golden rule ''"Never change the terrain under user's feets"'' is now totally wiped out from developer's mind.

Tons of problems to fix, and those ''developers'' chose to change the system appearence?!? O_o

To revert back to the default Ubuntu layout: '''System -> Preferences -> Appearence''' and select the Clearlooks Theme.
 
=== No icons on desktop in 10.04 ! ===

Where are the Home, System and the Trashcan icons? Is Nautilus broken? Is this a bug?

No.
They choosed to disable them by default.
They are '''GREAT ASSHOLES'''.

It's really incredible how those ''developers'' are happy to change the terrain under user's feets. This is the DUMBEST thing to do while administrating a system.

Just open '''gconf-editor''', go to '''Apps -> Nautilus -> Desktop''' and check every xxxx_icon_visible you need.


=== Ubuntuforums and freedom of speech ===

I posted this on Ubuntuforums:

{{attachment:yaf.png}}

just to obtain an infraction. Here is why:

{{{

DO NOT REPLY TO THIS EMAIL!
***************************

Dear asbesto,

You have received a new private message at Ubuntu Forums from xxxxxxxx, entitled "You have received an infraction at Ubuntu Forums".

To read the original version, respond to, or delete this message, you must log in here:
http://ubuntuforums.org/private.php

This is the message that was sent:
***************
Dear asbesto,

You have received an infraction at Ubuntu Forums.

Reason: Trolling
-------
Please do not post links to sites that troll Ubuntu and are full of profanity.


---Quote---
Trolling, Attacks and Flaming: These are always forbidden.
Trolling is posting in a way that provokes emotional responses.
Attacks and derogatory terms of any kind are not welcome. This includes references to other operating systems and the companies that produce them.
Flames are messages that personally attack or call any people names or otherwise harass. These, along with any generally condescending posts will be edited or removed at the moderators discretion.
If a thread is flame-bait (appears to be intended to start an argument or is likely to cause an argument rather than enhance discussion, as in trolling), it will be locked or removed without notice. Individual flame-bait comments in a post may be deleted or edited at the moderators' discretion.
---End Quote---

---Quote---
Profanity: We have users of all age groups and of all tolerance levels where profanity is concerned. A language filter is in place to catch most major forms of profanity that may accidentally be used. Do not attempt to circumvent the language filter by using variations or slight misspellings of profanities.
---End Quote---
-------

This infraction is worth 1 point(s) and may result in restricted access until it expires. Serious infractions will never expire.

Original Post:
http://ubuntuforums.org/showthread.php?p=12291864#post12291864

---Quote---
Hi there,

I feel extremely harassing to have my password asked FOREVER while working on MY laptop into MY account, with no other accounts, no open network connections and no security concern, closed into a vault 23 Km under a mountain.

I'm already logged in, I made my LOGIN, so why to ask FOREVER the same password, for configuring a PRINTER, a NETWORK CONNECTION or to make a SHUTDOWN? In my opinion this is extremely stupid.

So I found a way to solve this:


Code:
---------

cd /usr/share/polkit-1/actions
perl -i -pe 's/auth_admin_keep/yes/g' *.policy
perl -i -pe 's/auth_admin/yes/g' *.policy
perl -i -pe 's{<allow_inactive>no</allow_inactive>}{<allow_inactive>yes</allow_inactive>}g' *.policy
---------
More control over WHERE the system has to ASK passwords here:
http://lab.dyne.org/UbuntuPurification

:wink:
---End Quote---
- Hide quoted text -
All the best,
Ubuntu Forums
***************

Again, please do not reply to this email. You must go to the following page to reply to this private message:
http://ubuntuforums.org/private.php

All the best,
Ubuntu Forums

}}}

Where is "PROFANITY"?

{{{

DO NOT REPLY TO THIS EMAIL!
***************************

Dear asbesto,

You have received a new private message at Ubuntu Forums from xxxxxxxxxx, entitled "Signature".

To read the original version, respond to, or delete this message, you must log in here:
http://ubuntuforums.org/private.php

This is the message that was sent:
***************
Please remove the link to that site in your signature also.

http://lab.dyne.org/UbuntuPurification

If it is not done within 24 hours it will be done for you.
- Hide quoted text -
***************

Again, please do not reply to this email. You must go to the following page to reply to this private message:
http://ubuntuforums.org/private.php

All the best,
Ubuntu Forums

}}}

Is there a rule about signatures? I can't find it.

{{{

DO NOT REPLY TO THIS EMAIL!
***************************

Dear asbesto,

You have received a new private message at Ubuntu Forums from xxxxxxxxxx, entitled "You might want to rephrase that.".

To read the original version, respond to, or delete this message, you must log in here:
http://ubuntuforums.org/private.php

This is the message that was sent:
***************

---Quote---
Thank you for helping users removing crap from Ubuntu/Gnome
---End Quote---

Code:
---------
Attacks and derogatory terms of any kind are not welcome. This includes references to other operating systems and the companies that produce them.
---------

***************

Again, please do not reply to this email. You must go to the following page to reply to this private message:
http://ubuntuforums.org/private.php

All the best,
Ubuntu Forums

}}}

"crap" is not a denigratory term, is just my OPINION. SO... WELL, DEFINITIVELY NO, I DON'T WANNA REPRHASE THAT.

----
CategoryMuseo

GNU/Linux PURIFICATION

fuck2.jpg

Last update: Nov 3, 2019

Once upon a time, this was a page dedicated only to ubuntu distro; since many years I'm not using that shit anymore so this page evolved for general usage; the tricks described can be applied (with some minor tweaks) to almost any distro.

It's also my personal notepad for installing / dealing with my laptop, actually a Lenovo Thinkpad X220

I used Linux Mint for a lot of time, but they passed to the dark side ot that shitty cancer called systemd.

Now I'm using OUR distro, DEVUAN, a systemd-free old style full working GNU/Linux system! http://devuan.org :)

If you want to help developing this document, please write to asbesto (at) gmail {dot} com

Old version of this document is UbuntuPurificationOld

Check also:

Fresh devuan install: CLEANUP and SHIT

First we eradicate all the poettering bloatware shit, then we install what's needed in a serious UNIX system.

apt purge pulseaudio avahi-daemon avahi-autoipd 

apt install joe mc openssh-server build-essential apt-file locate qasmixer aptitude bsdgames

updatedb
apt-file update

THIS FUCKING TOUCHPAD

Once it was working. They broke it. Again.

Now, I have installed here xserver-xorg-input(libinput AND synaptics).

I don't touch anything than /etc/X11/xorg.conf, with this inside:

Section "Device"
  Identifier "Sucaminchia"
  Driver "intel"
EndSection

Section "dri"
  Mode 0666
EndSection

Section "InputClass"
    Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
            Option "TapButton1" "1"
            Option "TapButton2" "2"
            Option "TapButton3" "3"
        Option "VertEdgeScroll" "on"
        Option "HorizEdgeScroll" "on"
EndSection

On my thinkpad this is all I need. Touchpad is now working.

On the ASUS I have installed xinput (but I don't use it so I think isn't needed) and synclient.

Now, I can use synclient.

To enable tap to click: synclient TapButton1=1

Before, I had the edge scroll area TOO BIG, so to enlarge the touch pad area: synclient RightEdge=6100

There's NO FUCKING WAY to save those settings: everything in /usr/share/X11/xorg.conf.d/ is totally IGNORED.

So I tried .xsessionrc but it wasn't working either!!!

I had to create /usr/local/bin/synmerda:

sleep 5
/usr/bin/synclient TapButton1=1
/usr/bin/synclient RightEdge=6100
touch /tmp/usrlocalbin-synmerda

the 5 sec delay is NECESSARY because if not, for some FUCKING REASON, synclient settings can't work! FUUUUUUCK

and this in .xsessionrc:

/usr/local/bin/synmerda &
touch /tmp/PUTTANAMADONNA-puntoxsessionrc

About the poettering shit: avahi and pulseaudio removal

avahi and pulseaudio. Never saw such a pile of CRAP. let apt purge be, as shown before.

If you have some software that use pulseaudio crap and that you want to keep, use apt-mark. For example, I have this problem with pd-extended, so

apt-mark hold pd-extended # (because it depend on the pulseaudio-utils crap!!!)

So, to remove pulseaudio crap, use:

apt-get --ignore-hold  purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio gstreamer1.0-pulseaudio pavucontrol

To install everything needed for ALSA sound:

apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0

Installing software that require that pulseaudio CRAP as dependency

Example: pd-extended is by default compiled / linked / whatever to the fucking pulseaudio CRAP. In my Linux Mint it depends on the package pulseaudio-utils.

So, let's create a FAKE pulseaudio-utils package, just to keep apt quiet about it.

Install the "equivs" package:

apt-get install equivs

and use it to create a fake pkg description:

equivs-control pulseaudio-utils

This will create a file named pulseaudio-utils in the local directory. Edit it to something like this: (you can just copy this stuff into it: it works! :) )

Section: misc
Priority: optional
Standards-Version: 3.9.2

Package: pulseaudio-utils
Version: 1:42
Maintainer: Fuck Pulseaudio <fuckpulseaudio@example.com>
Architecture: all
Description: Pulseaudio FUCK YOU!

Note the Version: it prevent any overinstallation due to the very high value (42 ;) )

Now, create the fake package:

equivs-build ./pulseaudio-utils

And now, just install it:

dpkg -i ./pulseaudio-utils_42_all.deb

And so, now the dependency is satisfied and you have not to worry anymore! You can now install pd-extended and tweak his configuration to work with ALSA or JACK. ;)

* Very useful reference: http://shallowsky.com/blog/linux/install/blocking-deb-dependencies.html

mplayer and pulseaudio/alsa setup

You must configure the audio output in /etc/mplayer/mplayer.conf as follow:

# fuck pulse, use alsa, then SDL video
ao=alsa,sdl

updatedb, locate, mlocate

Here I just say 2 things:

  • DEBIAN SHIT!!!
  • INSTALL "mlocate", not "locate" !!!

audacious mp3 player

It must be configured (ctrl-p) as follow:

ALSA, 
Sysdefault:card=mid hda intel mix default analog audio dev, 
mixer hw:0 hda intel mid,
mixer element PCM.

ALSA and BLUETOOTH. FORGET IT!

EXPERIMENTAL: I FAILED. I can have a bt connection and direct aplay to use it, but there's no fucking way to switch from computer to bluetooth in any mixer I tried. So it's fucking useless apart from command line.

Scratchpad follow

sbc is needed:

git clone git://git.kernel.org/pub/scm/bluetooth/sbc.git
cd sbc/
less INSTALL
./bootstrap-configure
./configure
make
sudo make install

root@rover:~# apt-get remove pulseaudio
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libpulsedsp libsbc1 libwebrtc-audio-processing1 pulseaudio-utils rtkit
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  pulseaudio pulseaudio-module-bluetooth
0 upgraded, 0 newly installed, 2 to remove and 1 not upgraded.
After this operation, 6,285 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 146018 files and directories currently installed.)
Removing pulseaudio-module-bluetooth (10.0-1+deb9u1) ...
Removing pulseaudio (10.0-1+deb9u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
root@rover:~#


asbesto@rover:~/Desktop/src$ git clone https://github.com/Arkq/bluez-alsa.git
Cloning into 'bluez-alsa'...
remote: Enumerating objects: 104, done.
remote: Counting objects: 100% (104/104), done.
remote: Compressing objects: 100% (75/75), done.
remote: Total 3213 (delta 49), reused 62 (delta 28), pack-reused 3109
Receiving objects: 100% (3213/3213), 1.24 MiB | 1.05 MiB/s, done.
Resolving deltas: 100% (2472/2472), done.

asbesto@rover:~/Desktop/src$ cd bluez-alsa/

REQUIREMENTS: sudo apt install libbluetooth-dev libfdk-aac-dev libfdk-aac1

asbesto@rover:~/Desktop/src/bluez-alsa$ autoreconf --install

(blah blah)

mkdir build && cd build

NOTE: NO /usr/local prefix here, I want config files in the right places.

../configure --enable-aac --enable-ofono --enable-debug

make

sudo make install

launch "bluealsa" from /etc/rc.local

 bluealsa -S &

cat > ~/.asoundrc

defaults.bluealsa.service "org.bluealsa"
defaults.bluealsa.device "55:0B:D4:79:E3:30"
defaults.bluealsa.profile "a2dp"
defaults.bluealsa.delay 10000

aplay -D bluealsa file.wav works! 

No mixer can see / recognize the "bluealsa" device. FUCK THIS SHIT

AND:

It is not possible to run more than one instance of the BlueALSA server per D-Bus interface. If one tries to run second instance, it will fail with the "Couldn't acquire D-Bus name: org.bluealsa" error message. This message might also appear when D-Bus policy does not allow acquiring "org.bluealsa" name for a particular user - by default only root is allowed to start BlueALSA server.

what the actual FUCK

TO REVERT AND RE-INSTALL PULSESHIT

Uninstall bluez-alsa from the install directory (enter "build" dir and do make uninstall)

and

apt install pulseaudio pulseaudio-module-bluetooth

Sorry. If you want alsa instead of pulseshit, you can't use bluetooth.

NOTE:

I had chrome on external bt audio and telegram on pc auto. To set default output:

pactl set-default-sink 1

tnx to Nightolo! :)

asbesto@rover:~$ pactl list sinks > petazzo
asbesto@rover:~$ pactl list sources >> petazzo
asbesto@rover:~$ pacmd list sink-inputs > petazzo
asbesto@rover:~$ pactl set-default-sink 1
asbesto@rover:~$

Acrobat reader for linux

Get it from here: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/

dpkg --add-architecture i386
sudo apt-get update
dpkg -i Desktop/AdbeRdr9.5.5-1_i386linux_enu.deb

After that, fix the broken install shit and install the last requirement:

apt --fix-broken install
apt install libxml2:i386

That's it!

Too many password asked. Why removing them? Is it safe?

Typical situation is: my laptop have only my personal account in it, and no other users. no open ports, no ssh server, no telnet, no shared folders, no samba, nothing.

I'm the only user of it.

So I log in (password), 
and configure a printer (password), 
I check network settings (password) 
install packages (password), 
remove a package (password again) 
become su (password), 
use sudo! (another password), 
configure stuff in gnome (password again) 
configure a new network connection (password again!!!)
quit the system (another password!!!)

THIS - IS - FUCKING - STUPID

This document contain useful hints to CLEAN UP THIS MESS, obtaining a nice working GNU/Linux system instead of the crap installed and configured by default.

Automatic login without password

It's MY computer, in MY house, so why the FUCK i have to type my password to log in X-Windows?!?

System - Administration - Login and select the damn user

You can select this while installing Linux Mint.

OLD: IDIOT keyring password

It will be asked again and again. Every time the same FUCKING password. Just to open a thing that contain THE SAME PASSWORD ITSELF. Delete the folder $home/.gnome2/keyrings which holds the keyring info. Once you do that it wont ask again.

On Mint 13 - Maya (mate edition), these files are at: $home/.config/mate/keyrings (Thanks to Derrik Arenal for the suggestion!)

OLD: Disable the damn Gnome Keyring Manager Password

Where is it in Mint 17?

FUCK MINT 17 KEEPS ASKING PASSWORDS AND KEYRING FILE IS NO MORE IN THE PLACe
THIS IS AN EMERGENCY PLEASE HELP WHERE THE HELL IT IS NOW -jrml

Get rid of all those asked passwords

Create a file named /etc/pam.d/common-pamkeyring with this inside:

auth optional pam_keyring.so try_first_pass
session optional pam_keyring.so

Edit /etc/pam.d/mdm as follow: (was gdm but this is Mint! it can be lightdm - check it out)

add

@include common-pamkeyring

at the bottom, and please COMMENT OUT those lines:

# auth optional pam_gnome_keyring.so
# session optional pam_gnome_keyring.so auto_start

Create, if doesn't exist, the wheel group, editing /etc/group, and add your user to it

vi /etc/group

Edit /etc/sudoers, using visudo

visudo

adding:

%wheel ALL=(ALL:NOPASSWD) ALL
yourusername    ALL=(ALL) NOPASSWD: ALL

Edit /etc/pam.d/sudo adding at bottom:

auth sufficient pam_rootok.so
auth required pam_wheel.so
auth sufficient pam_wheel.so trust

Edit /etc/pam.d/su enabling this line (just uncomment it):

# Uncomment this if you want wheel members to be able to
# su without a password.
auth sufficient pam_wheel.so trust

The Incredible Idiocy: PolicyKit

As I stated in ubuntuforums time ago:

I'm used to work on MY computer, with MY login, and no other logins; it's in MY home, and it don't run away to search for malicious users. It's MY PC in MY HOUSE. For this I log in automagically with no password asking. I have automagic "su" and "sudo" without password (that is STUPID because I'm root on MY machine, and there are NO other users).

But now I have some very annoying issues about this damn thing called "System Policy", for which I can't, just to say, do a shutdown of my machine under Gnome because "System policy prevents stopping the system when other users are logged". And this just because I have some root terminals left open.

This is very, very stupid.

And so on, this damn system policy crap keep asking me the same damn password for everything: wifi connections, login/ssh to other machines, mounting of devices, and so on.

Please, PLEASE. Does someone know HOW TO KILL this stupid thing? How to get rid of all those unuseful, boring, recursive and idiot password requests?

please somebody help me, I'm going nuts for this.

I got an official warning and the thread was closed by administrator. The PolicyKit was a so stupid PIECE OF CRAP that now is no more used. But for the unfortunate users that have this stinking corpse running in the system, here's a solution.

Assuming you have sudo settings as above, do

usermod -aG sudo yourname

Replace "username" with your actual user name. Now switch to root:

sudo -i

Create a new policy:

vi /var/lib/polkit-1/localauthority/50-local.d/fuck-passwords.pkla

Add this:

[Install package file]
Identity=unix-group:sudo
Action=*
ResultActive=yes

Save, exit, and reboot. No more Policy Kit password requests!

OLD POLKIT VERSION patch

As stated in the man page just edit /etc/PolicyKit/PolicyKit.conf as here:

<config version="0.1">
        <match user="root|YOUR_USER_HERE">
               <return result="yes"/>
        </match>
        <define_admin_auth group="admin|wheel"/>
</config>

and restart the whole X damn thing

NOW LIVE IN HAPPINESS

Other stupid things

Sometimes the default behaviour of Debian is to install unuseful CRAP as "recommended" and "suggested" packages. Here's how to avoid it:

vim /etc/apt/apt.conf.d/fucksuggested.conf

APT:Install-Recommends "0";
APT:Install-Suggests "0";

(thanks to Franco Lanza for this hint! ;) )

ls -la: BAD sorting order

The normal behaviour of ls -la command since beginning of UNIX is, and has to be:

-rw-r--r--  1 sm01 sm01   0 May  3 18:32 .aaa 
-rw-r--r--  1 sm01 sm01   0 May  3 18:33 .fff 
-rw-r--r--  1 sm01 sm01   0 May  3 18:33 DDD 
-rw-r--r--  1 sm01 sm01   0 May  3 18:33 EEE 
-rw-r--r--  1 sm01 sm01   0 May  3 18:32 bbb 
-rw-r--r--  1 sm01 sm01   0 May  3 18:32 ccc 

Now with all this LOCALE SHIT around, you can obtain this:

-rw-r--r--  1 sm01 sm01   0 may  3 18:32 .aaa 
-rw-r--r--  1 sm01 sm01   0 may  3 18:32 bbb 
-rw-r--r--  1 sm01 sm01   0 may  3 18:32 ccc 
-rw-r--r--  1 sm01 sm01   0 may  3 18:33 DDD 
-rw-r--r--  1 sm01 sm01   0 may  3 18:33 EEE 
-rw-r--r--  1 sm01 sm01   0 may  3 18:33 .fff 

If you want to avoid this fucking abomination, just add

export LC_COLLATE="C"

to your .bash_profile .zshrc or /etc/rc.local ;)

(Thanks to Fabio "Elettrico" Moretti for this hint ;) )

Pulseaudio CRAP

Pulseaudio is CRAP added for stupid reasons. A system without Pulseaudio is more responsive and everything work fine without this fucking daemon sucking about 13% of a Netbook CPU. So, get rid of it!

On my Linux Mint 15 Mate Edition, I just removed it:

apt-get purge pulseaudio

Nothing has changed on my system, and so I have 13% CPU free :) I can play everything as usual.

Command not found handler

I hate it. It slow the responsivness of my shell. so

apt-get remove command-not-found command-not-found-data

Close this terminal?

Are you kidding? YES, CLOSE THAT FUCKING TERMINAL, HOLY SHIT

Terminal asking "Close this terminal? There is still a process running in this terminal. Closing the terminal will kill it" is really, really stupid and BORING.

Install dconf-tools

apt-get install dconf-tools

Launch dconf-editor -> org -> mate -> terminal -> global -> untick confirm_window_close

Sticky Windows at edges

The most annoying thing in the entire world. The great stupid thing is that you have compiz installed without the tool for configuring it!

so, apt-get install compizconfig-settings-manager and check out the snapping windows option in the window management section of the compiz config editor, that is under system - preferences menu.

This setup can also be found into other parts of Desktop Manager configuration...

USEFUL programs that are not installed by default

  • traceroute - incredible. traceroute is not installed by default. O_O
  • compizconfig-settings-manager (compiz INSTALLED and NOT CONFIGURABLE? STUPID!)
  • openssh-server (this is SO FUGKING STUPID!)
  • mc
  • gimp
  • joe

SHIT to be removed

  • f-spot
  • totem (totally unuseful!)
  • conduit (Who give a FUCK to sync ?!?)

About this document, his License/Terms of Use, etc.

Copyright © 2000 Gabriele "asbesto" Zaverio <asbesto@gmail.com>
This work is free. You can redistribute it and/or modify it under the
terms of the Do What The Fuck You Want To Public License, Version 2,
as published by Sam Hocevar. See http://www.wtfpl.net/ for more details.

WTFPL License

            DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
                    Version 2, December 2004

 Copyright (C) 2004 Sam Hocevar <sam@hocevar.net>

 Everyone is permitted to copy and distribute verbatim or modified
 copies of this license document, and changing it is allowed as long
 as the name is changed.

            DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
   TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

  0. You just DO WHAT THE FUCK YOU WANT TO.

Is this document offensive / inappropriate / not corporate compliant for you?

I want to cite the WTFPL about this:

Can’t you change the wording? It’s inappropriate / childish / not corporate-compliant.

The WTFPL lets you relicense the work under any other license.

But profanity is offensive!

You know what? Fuck your stance on profanity. Fuck your priorities in life. The WTFPL is about fucking freedom and we mean it. Freedom means freedom to copy and modify and share works of art and science with the rest of mankind, but also freedom to be gay and marry and have crazy gay sex, freedom to have tattoos, freedom to say there is no God, freedom to take the pill, freedom to have an abortion. People die for being gay or atheists. Don’t tell me that there is something sacred enough that it must be protected from the mere existence of the word “fuck”. If the F in WTFPL offends you, then fuck you and your beliefs. Triple fuck you.

Threads about stupid things added in Ubuntu

Totem

Totem is installed by default. But it's UNABLE to open ANYTHING. WHY?

NO CODECS INSTALLED!

O_O

Ubuntu 10.04 horrible windows layout

The default windows appearence in Ubuntu 10.04 is a SHAME. The golden rule "Never change the terrain under user's feets" is now totally wiped out from developer's mind.

Tons of problems to fix, and those developers chose to change the system appearence?!? O_o

To revert back to the default Ubuntu layout: System -> Preferences -> Appearence and select the Clearlooks Theme.

No icons on desktop in 10.04 !

Where are the Home, System and the Trashcan icons? Is Nautilus broken? Is this a bug?

No. They choosed to disable them by default. They are GREAT ASSHOLES.

It's really incredible how those developers are happy to change the terrain under user's feets. This is the DUMBEST thing to do while administrating a system.

Just open gconf-editor, go to Apps -> Nautilus -> Desktop and check every xxxx_icon_visible you need.

Ubuntuforums and freedom of speech

I posted this on Ubuntuforums:

yaf.png

just to obtain an infraction. Here is why:

DO NOT REPLY TO THIS EMAIL!
***************************

Dear asbesto,

You have received a new private message at Ubuntu Forums from xxxxxxxx, entitled "You have received an infraction at Ubuntu Forums".

To read the original version, respond to, or delete this message, you must log in here:
http://ubuntuforums.org/private.php

This is the message that was sent:
***************
Dear asbesto,

You have received an infraction at Ubuntu Forums.

Reason: Trolling
-------
Please do not post links to sites that troll Ubuntu and are full of profanity.


---Quote---
Trolling, Attacks and Flaming: These are always forbidden.
Trolling is posting in a way that provokes emotional responses.
Attacks and derogatory terms of any kind are not welcome. This includes references to other operating systems and the companies that produce them.
Flames are messages that personally attack or call any people names or otherwise harass. These, along with any generally condescending posts will be edited or removed at the moderators discretion.
If a thread is flame-bait (appears to be intended to start an argument or is likely to cause an argument rather than enhance discussion, as in trolling), it will be locked or removed without notice. Individual flame-bait comments in a post may be deleted or edited at the moderators' discretion.
---End Quote---

---Quote---
Profanity: We have users of all age groups and of all tolerance levels where profanity is concerned. A language filter is in place to catch most major forms of profanity that may accidentally be used. Do not attempt to circumvent the language filter by using variations or slight misspellings of profanities.
---End Quote---
-------

This infraction is worth 1 point(s) and may result in restricted access until it expires.  Serious infractions will never expire.

Original Post:
http://ubuntuforums.org/showthread.php?p=12291864#post12291864

---Quote---
Hi there,

I feel extremely harassing to have my password asked FOREVER while working on MY laptop into MY account, with no other accounts, no open network connections and no security concern, closed into a vault 23 Km under a mountain.

I'm already logged in, I made my LOGIN, so why to ask FOREVER the same password, for configuring a PRINTER, a NETWORK CONNECTION or to make a SHUTDOWN? In my opinion this is extremely stupid.

So I found a way to solve this:


Code:
---------

cd /usr/share/polkit-1/actions
perl -i -pe 's/auth_admin_keep/yes/g' *.policy
perl -i -pe 's/auth_admin/yes/g' *.policy
perl -i -pe 's{<allow_inactive>no</allow_inactive>}{<allow_inactive>yes</allow_inactive>}g' *.policy
---------
More control over WHERE the system has to ASK passwords here:
http://lab.dyne.org/UbuntuPurification

:wink:
---End Quote---
- Hide quoted text -
All the best,
Ubuntu Forums
***************

Again, please do not reply to this email. You must go to the following page to reply to this private message:
http://ubuntuforums.org/private.php

All the best,
Ubuntu Forums

Where is "PROFANITY"?

DO NOT REPLY TO THIS EMAIL!
***************************

Dear asbesto,

You have received a new private message at Ubuntu Forums from xxxxxxxxxx, entitled "Signature".

To read the original version, respond to, or delete this message, you must log in here:
http://ubuntuforums.org/private.php

This is the message that was sent:
***************
Please remove the link to that site in your signature also.

http://lab.dyne.org/UbuntuPurification

If it is not done within 24 hours it will be done for you.
- Hide quoted text -
***************

Again, please do not reply to this email. You must go to the following page to reply to this private message:
http://ubuntuforums.org/private.php

All the best,
Ubuntu Forums

Is there a rule about signatures? I can't find it.

DO NOT REPLY TO THIS EMAIL!
***************************

Dear asbesto,

You have received a new private message at Ubuntu Forums from xxxxxxxxxx, entitled "You might want to rephrase that.".

To read the original version, respond to, or delete this message, you must log in here:
http://ubuntuforums.org/private.php

This is the message that was sent:
***************

---Quote---
Thank you for helping users removing crap from Ubuntu/Gnome
---End Quote---

Code:
---------
Attacks and derogatory terms of any kind are not welcome. This includes references to other operating systems and the companies that produce them.
---------

***************

Again, please do not reply to this email. You must go to the following page to reply to this private message:
http://ubuntuforums.org/private.php

All the best,
Ubuntu Forums

"crap" is not a denigratory term, is just my OPINION. SO... WELL, DEFINITIVELY NO, I DON'T WANNA REPRHASE THAT.


CategoryMuseo

GnuLinuxPurification (last edited 2019-11-18 12:00:47 by asbesto)